あれこれ備忘録@はてなブログ

勉強したことやニュースや出来事を備忘録として書いていきます

PC

FirefoxなどのブラウザでID,パスワードが盗み取られる脆弱性があるらしい。

気になるツイートを見つけた。 ブラウザのautofillを使ってパスワードを盗むデモ。Firefoxの場合はabout:configからsignon.autofillFormsをfalseにする事で防げるんだけど、設定UIからは変更できない?ちなみに昔あったSecure Loginという拡張は、DOMに入力せ…

ある日のAbemaTV(アベマティーヴィー)のコメント欄

今、AbemaTVでアルフを放送している。 アルフ 〈シーズン1-4〉 コンプリートDVD BOX(24枚組) [初回限定生産]posted with カエレバ所ジョージ ワーナー・ホーム・ビデオ 2012-06-06 Amazonで探す楽天市場で探すYahooショッピングで探す7netで探す 先日、…

Chrome,Operaの拡張機能(エクステンション)をそのままFirefoxで使えるようにするアドオン

こんな記事を読んだ。 wired.jp Firefoxがバージョン57(Firefox Quantum)になって、Chrome並みに高速になり、Chromeよりもメモリ消費量が少ない、Firefox Quantumに追加された新機能が便利なことから、ChromeからFirefoxへ乗り換える状況になったという記事…

XenialPup64(Puppy Linux)がバージョン7.5として公式に。安定動作している。ハングする原因らしきものも調べてみた

Index of /puppylinux/puppy-xenial/ Puppy Linux Release Announcement これまでテスト版のみだった、32bitのXenialPupと64bit版のXenialPup64がバージョン7.5で公式版になった。 カーネルが4.9だったことがあって、きっと動かないんだろうな・・・と思って…

ダニエル・シフマン(Daniel Shiffman)のCoding Trainが面白い。

http://shiffman.net/ Daniel Shiffman - Wikipedia ダニエル・シフマンはProcessingというJavaベースのグラフィックス開発のプログラミング言語を作っている財団のリード・デベロッパーで芸術系の学校の准教授だそうだ。 同学校のインタラクティブテレコミ…

Mozilla、Firefoxがこれまで以上の個人情報を集める計画。すでに一部で実施

Firefoxが激重だということで一部で問題になっている。 arekorebibouroku.hateblo.jp サードパーティのアドオンやセキュリティソフトのせいだったりするので、Firefoxには気の毒なところもあるが、この問題で他のブラウザに乗り換える人が増えていると思う。…

Firefox Quantumが激重になる問題が発生中

2017/12/08 追記 Mozilla、「Firefox」v57.0.2を公開 〜“Critical”な脆弱性を1件修正 - 窓の杜 またバージョンアップされてます。 今度こそ、不具合直ったんでしょうかね? 2017/11/30 追記 「Firefox Quantum」v57.0.1が公開、一部環境で動作が異常に遅くな…

Ubuntu17.10ベースのPuppy LinuxであるArtfulPupを試してみる

Puppy Linux Discussion Forum :: View topic - ArtfulPup 16.04ベースのXenialPup64がうちのマシンでは動かなかった。 そこでSlacko64を試してみた。 Slacko64にはカーネルバージョンの異なるイメージが3つあり、XenialPup64と同じ、ver. 4.9のものはやっぱ…

WINEでアルファベットが豆腐になってしまう不具合とWINE安定版がインストールできない不具合

Ubuntu(Lubuntu)を16.04から17.04にアップデートしてからWINEを起動してみたらアルファベットが豆腐になっていた。 以前は日本語が豆腐に文字化けする問題があった。 しかし、不思議なことに今回はアルファベットの方が豆腐なのだ。 色々試したがうまくいか…

AbemaTVのウォーキング・デッドがDRMなしで見られるようになっているようだ

今、AbemaTVでウォーキング・デッドのシーズン3を配信中だ。 これまで字幕版がメインで、後になってからチャンネルを2つ用意して吹き替えと字幕の両方を配信するという粋なはからいをしていた。 シーズン3では何故か字幕版のみの放送となった。 先日、気づい…

WPA2の脆弱性KRACK対応のセキュリティアップデートをPuppy Linux(TahrPup,XenialPup)に適用した

先日、WPA2の脆弱性が発表されましたよね。 wired.jp www.itmedia.co.jp 基本的にクライアント側で対応すれば良いらしく、多くのOSではすぐにセキュリティアップデートで対応されたはずです。 Linuxディストリビューションも有名なところは対応されたと思い…

古いマシンにXenialDog64をインストールしたら快適だった。Puppy Linux(TahrPup,XenialPup)からの乗り換えにも最適

2016年に販売されたノートパソコンDell Inspiron 1501にXenialDog64をインストールしてみた。 CPUはAMD Turion64 X2が搭載されている。 これはデュアルコアでしかも64bitに対応したCPUなので64bit版のOSがインストールできるのである。 以前、インストールし…

Firefoxアドオン配布サイトでアドオンの機能を使えるようにする

Firefoxアドオンのサイトで、翻訳をしようと思ったのですが、テキストを選択しても翻訳ボタンのポップアップが出てこないということがありました。 それほど使うわけではありませんが、ちょっと不便だなと思っていました。 そんなことを思っていたところ、Tw…

Firefox Quantumが話題だそうなのでちょっと試してみた(と言ってもNightlyだけど)

2017/11/21 追記 Firefox Quantumが重くなる現象が一部のユーザーで発生しているようだ。 ネットの情報を集めてみた。 arekorebibouroku.hateblo.jp 「Firefox Quantum」が話題だ。 Firefoxの新バージョン「Quantum」、エンジン刷新で約2倍に高速化 - Comput…

Anthyの辞書強化がうまくいっていない。原因らしきものについて

arekorebibouroku.hateblo.jp 先日、Anthyの辞書を強化してみた。 しかし、どうも登録したはずの単語が変換で出てこない。 ちょっと調べてみたところ、以下の不審な点が見つかった。 「/etc/anthy/diclist」に「/usr/share/anthy/dic」ディレクトリに入れた…

日本語入力ソフト・日本語変換エンジンに関する色々。歴史とかオンラインIMEとか

MozcのビルドやAnthyの辞書強化などをしたことで、ちょっと日本語入力ソフトあるいは日本語変換エンジンに興味が出てきた。 https://www.ospn.jp/osc2016-kyoto/pdf/OSC2016_Kyoto_openmanyo.pdfwww.ospn.jp ホットな日本語入力技術のお勉強。〜 OSC 2016 Ha…

XenialDog(Puppy Linux系)Anthyの辞書をできる限り強化してみた(かなり頭が良くなった)

XenialDogに、rootで使えるMozcをビルドしてインストールする試みは失敗した…。 原因がまだ分からないのでとりあえずはAnthyを使うことにした。 arekorebibouroku.hateblo.jp ここの記事にも書いてあるようにPuppy Linuxの日本語フォーラムでrootで使えるSCI…

(Rootの方は不完全ながら成功)Rootで使えるMozc、あるいはMozc-UTをビルドするまでの長く険しい道のり

Mozcの辞書を強化する事を目的としたMozc UT2 Dictionary(元はMozc UT Dictionary)というものがある。 http://www.geocities.jp/ep3797/mozc-ut2.html しかし、これはArch Linuxを想定しているため、他のディストリビューションには敷居が高い。 これをDebia…

(追記あり : 大分使いやすくなった ! )XenialDog64を試してみた。なかなか良い感じ。しかし、色々うまくいかない。

XenialDog 64-bit apt-getやSynapticパッケージマネージャが使えるPuppy Linux的なディストリビューションとして有名なDebianDogの派生でUbuntu 16.04ベースのXenialDogの64ビット版を試してみた。 Ubuntuなどを既にインストールしてあって、Grub2が入ってい…

(追記あり)Linux版Flash Player プラグイン Firefox用NPAPI版 バージョン27で音が出ない不具合(Ubuntu,Debian,openSUSE,CentOS,Arch Linuxなど)

2017/10/30 追記 Adobe Flash Player 27.0.0.159以降(現在のバージョンは24.0.0.194)では解決しているようです。 AdobeのFlash Playerがバージョンアップされ、27.0.0.130になった。 しかし、アップデートされてからFirefoxでFlashの動画やコンテンツを動か…

Kona Linuxに関する記事が2ちゃんねるで言及されていた

arekorebibouroku.hateblo.jp 上の記事が.scの方の2ちゃんねるで言及されていた。 Kona Linux 3杯 この書き込みは別に構わないのだが、それに対する反応が気になった。 https://maguro.2ch.sc/test/read.cgi/linux/1475762994/1096 精神の方向性が常に後ろ向…

ffmpegを使って動画形式を変換したらファイルサイズが激減した

あるテレビ番組の動画をPCに取り込んだのだが、とてもファイルサイズが大きい。 ハイビジョンやフルハイビジョン、4Kに8Kの時代なので、1つの番組で数GBは今は当たり前なのかも知れない。 しかし、個人的にはそんなに綺麗な映像で無くてもサイズが多少小さ…

Kona LinuxとかLubuntuの聴き比べで使用していたお気に入りの曲、高音質の曲

先日、こんな記事を書いた。 arekorebibouroku.hateblo.jp arekorebibouroku.hateblo.jp これでKona LinuxのJACKとLubuntuのPulseAudioの聴き比べをした。 YouTubeの動画であること、元の音質以上には良くはならないことはわかっていたが、手軽に聞けること…

Puppy Linuxを自動で作ることができるスクリプトmakepupを試してみたが・・・

Puppy Linux Discussion Forum :: View topic - Auto-build woof-CE Pup using single script with optional gui 最近、話題らしく、日本でも幾つかのブログで取り上げられている。 流行に乗るのも悪くは無いが、個人的には公式サイトなどで配布されているPu…

(追記あり)Firefox アドオンのuBlock Originが動かなくなる不具合、Web Extension版への移行が待ったなし

2017/11/10 追記 バージョン57で旧式のアドオンが使えなくなるので、有名どころのアドオンのWeb Extensions版対応状況や代替アドオンを探してみた。 arekorebibouroku.hateblo.jp 参考にしてみてほしい。 2017/09/04 追記 Android版Firefoxではまだうまく動…

ハイレゾ音源が聞けるか!?Ubuntu(Lubuntu)でPulseAudioの音質が良くなるかも知れない設定をしてみた。他のLinuxディストリでも

先日、KonaLinux 4.0 blackjackエディションを試して、音質にこだわる人たちの存在とその取り組みを身近に感じた。 arekorebibouroku.hateblo.jp JACKやALSAと比べてPulseAudioの音質に関する評判が悪いことも知った。 細かいところはまだ足りないのかも知れ…

Puppy Linux(TahrPup,XenialPupなど)でモニタの解像度が低くなってしまう不具合(Ubuntuなどでも起こるらしい)の対処法

うちのPuppy Linuxを入れているマシンにつないでいるモニタはこれまでずっと1024x768が最大の解像度で、ずっとそのまま使ってきた。 あるとき、モニタにRESOLUTION NOTIFIERという機能があり、これをオンにして見たところ、「最適信号は1280x1024」だと表示…

軽量Linuxにも64bitの波が。64bit版のPuppy Linux(TahrPup64,XenialPup64)でWineを動かす

世の中の多くのOSが64bitが当たり前になってきている。 モバイル端末のCPUも64bit対応が出てきて、Androidにも64bit版がある。 ChromeなどLinuxの32bit版はサポートが終了している。 アプリケーションでも32bit版がないものがこれから増えるだろう。 時代の…

Puppy Linux(TahrPup)でDRM付きの映画やドラマが見られなくなっていた

2017/08/30 追記 Firefoxのバージョンを新しくしたためか、FirefoxでもDRMコンテンツが見られるようになった。 それでも動画が何度も繰り返されたり途切れたりと不安定になることもあるので、Chromiumも導入し、安定している方で見ることにすると良いと思う…

(55以降でもapulseを使えるようにする方法)Puppy Linux(TahrPup,XenialPup)でFirefoxを使う場合はPulseAudioをインストールする必要がある

以下の記事の下に書いてある方法を使うことでFirefoxバージョン57でもapulseを使ってYouTube、AbemaTVが問題なく再生できました。 arekorebibouroku.hateblo.jp 参考にしてください。 記事の最後にバージョン55以降でもapulseが使えるようにする方法を追記し…